手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

求助好心人看看MACD顶底背离自动画线副图指标【通达信】的公式错在什么地方

[通达信]
设置
31778 26 漫2010 Lv.4 发表于 · 2015-6-7 22:48 举报 只看楼主 复制 倒序浏览 |
跳转到指定楼层
网上找到的看贴图貌似不错,可是我的通达信装不上,不知道错在哪里,有那位好心人帮忙解决,谢谢
MACD顶底背离自动画线副图指标【通达信】
{MACD背离划线
SHORT 5 40 12
LONG 10 100 26
M 2 40 9}
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD:=2*(DIFF-DEA);
Zero : 0;
gj:=MAX(C,O);
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,2,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,2,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,2,0),color00ff00;
L4:=LLV(gj,4);
jl:=(HHV(diff,55)-LLV(diff,55))/5;
gt:=dea>REF(dea,1) AND REF(dea,1)<REF(dea,2);
A1:=BARSLAST(REF(gt,1));
底背离:=REF(L4,A1+1)>CLOSE AND diff>REF(diff,A1+1) AND gt;
DRAWLINE(A1=0,DEA,底背离,REF(DEA,A1),0),colorred,LINETHICK2;
DRAWLINE(底背离,DEA,底背离,REF(DEA,A1),0),colorred,LINETHICK2;
DRAWTEXT(底背离,REF(DEA,A1)*1.18,' 底背离'),COLORFF00FF;
H4:=HHV(gj,4);
gt2:=dea<REF(dea,1) AND REF(dea,1)>REF(dea,2);
A2:=BARSLAST(REF(gt2,1));
顶背离:= REF(H4,A2+1)<H4 AND diff<REF(diff,A2+1) AND gt2;
DRAWLINE(A2=0 ,DEA,顶背离,REF(DEA,A2),0),colorgreen,LINETHICK2;
DRAWLINE(顶背离,DEA,顶背离,REF(DEA,A2),0),colorgreen,LINETHICK2;
DRAWTEXT(顶背离,REF(DEA,A2)*1.18,' 顶背离'),colorgreen;

举报

扔鸡蛋(0) 回复

鬼舞十七
Lv.4
发表于 2015-6-7 23:46 复制 2楼 只看该作者
公式没错,将下面  SHORT :   5 40 12     LONG:   10 100 26      M:  2 40 9  三个参数分别填上即可。


DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD:=2*(DIFF-DEA);
Zero : 0;
gj:=MAX(C,O);
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,2,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,2,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,2,0),color00ff00;
L4:=LLV(gj,4);
jl:=(HHV(diff,55)-LLV(diff,55))/5;
gt:=dea>REF(dea,1) AND REF(dea,1)<REF(dea,2);
A1:=BARSLAST(REF(gt,1));
底背离:=REF(L4,A1+1)>CLOSE AND diff>REF(diff,A1+1) AND gt;
DRAWLINE(A1=0,DEA,底背离,REF(DEA,A1),0),colorred,LINETHICK2;
DRAWLINE(底背离,DEA,底背离,REF(DEA,A1),0),colorred,LINETHICK2;
DRAWTEXT(底背离,REF(DEA,A1)*1.18,' 底背离'),COLORFF00FF;
H4:=HHV(gj,4);
gt2:=dea<REF(dea,1) AND REF(dea,1)>REF(dea,2);
A2:=BARSLAST(REF(gt2,1));
顶背离:= REF(H4,A2+1)<H4 AND diff<REF(diff,A2+1) AND gt2;
DRAWLINE(A2=0 ,DEA,顶背离,REF(DEA,A2),0),colorgreen,LINETHICK2;
DRAWLINE(顶背离,DEA,顶背离,REF(DEA,A2),0),colorgreen,LINETHICK2;
DRAWTEXT(顶背离,REF(DEA,A2)*1.18,' 顶背离'),colorgreen; @漫2010

举报

点亮(0) 扔鸡蛋(0) 回复

漫2010
Lv.4
发表于 2015-6-8 06:44 复制 3楼 只看该作者
谢谢鬼舞十七老师,问题已解决,祝鬼舞十七老师投资顺利。同时感谢理想论坛给了小散免费分享技术,数据的平台。

举报

点亮(0) 扔鸡蛋(0) 回复

漫2010
Lv.4
发表于 2015-6-13 17:23 复制 4楼 只看该作者
怎么好的公式,这么多的人浏览,没有一个人给我评论,加分,汗,看样子是我的人品不好。

举报

点亮(0) 扔鸡蛋(0) 回复

酷得这么无奈
Lv.1
发表于 2015-8-12 03:30 复制 5楼 只看该作者
原帖由 @漫2010 于 2015-6-13 17:23 发表
怎么好的公式,这么多的人浏览,没有一个人给我评论,加分,汗,看样子是我的人品不好。

不太会弄啊

举报

扔鸡蛋(0) 回复

知我罪我
Lv.3
发表于 2015-9-17 12:23 复制 6楼 只看该作者
@鬼舞十七 当前公式 : 背离 (指标画线公式)  
错误句 : DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG)
详细信息 : 未知字符串 SHORT
错误起始位置 : 17 ; 长度: 5
乍回事,老师!

举报

点亮(0) 扔鸡蛋(0) 回复

鬼舞十七
Lv.4
发表于 2015-9-17 14:32 复制 7楼 只看该作者
SHORT :   5 40 12     LONG:   10 100 26      M:  2 40 9  三个参数分别填上@知我罪我

举报

点亮(0) 扔鸡蛋(0) 回复

知我罪我
Lv.3
发表于 2015-9-17 15:55 复制 8楼 只看该作者
@鬼舞十七 填写在哪里呀?

举报

点亮(0) 扔鸡蛋(0) 回复

鬼舞十七
Lv.4
发表于 2015-9-17 22:06 复制 9楼 只看该作者
打开公式管理器 参数的地方填上以上数据 @知我罪我

举报

点亮(0) 扔鸡蛋(0) 回复

纠结帝
Lv.1
发表于 2015-12-13 12:35 复制 10楼 只看该作者
我按照这个复制粘贴 为什么出来
当前公式 : MACD顶底背离 (指标画线公式)  
错误句 :
?:= REF(H4,A2+1)<H4 AND DIFF<REF(DIFF,A2+1) AND GT2
详细信息 : 变量 ? 定义重复!
错误起始位置 : 783 ; 长度: 8
请教一下怎么弄呢?

举报

点亮(0) 扔鸡蛋(0) 回复

现代金属
Lv.3
发表于 2016-1-10 14:32 复制 11楼 只看该作者
看图    对你有用的话   请给我加分

[ 本帖最后由 现代金属 于 2016-1-10 14:34 编辑 ]

举报

点亮(0) 扔鸡蛋(0) 回复

现代金属
Lv.3
发表于 2016-1-10 14:43 复制 12楼 只看该作者
MACD画背离.tne (7.63 KB, 下载次数: 121) MACD背离自动画线   




效果图

[ 本帖最后由 现代金属 于 2016-1-10 14:46 编辑 ]

附件

捕获3333.JPG

65.73 KB, 下载次数: 3

捕获3333.JPG

举报

点亮(0) 扔鸡蛋(0) 回复

蓝天游
Lv.1
发表于 2016-5-2 19:08 复制 14楼 只看该作者
新手没有币不可以下载,怎么样才可以下载啊

举报

扔鸡蛋(0) 回复

莱科宁00
Lv.2
发表于 2016-12-1 13:58 复制 16楼 只看该作者
you yong

举报

扔鸡蛋(0) 回复

莱科宁00
Lv.2
发表于 2016-12-1 14:00 复制 18楼 只看该作者
不错有用啊 可与啊

举报

扔鸡蛋(0) 回复

柳樱
Lv.1
发表于 2016-12-10 16:41 复制 19楼 只看该作者
感谢老师分享

举报

扔鸡蛋(0) 回复

吹风007
Lv.3
发表于 2017-1-17 00:50 复制 20楼 只看该作者
感谢老师分享
谢谢

举报

扔鸡蛋(0) 回复

股海浮升
Lv.1
发表于 2017-2-16 18:15 复制 21楼 只看该作者
老师给的指标里面有未来函数

举报

扔鸡蛋(0) 回复

乐活股神
Lv.2
发表于 2017-10-4 01:34 复制 22楼 只看该作者
底背离自动画线副

举报

扔鸡蛋(0) 回复

熊大人儿
Lv.2
发表于 2018-1-29 20:10 复制 24楼 只看该作者
可惜,是画金叉死叉的背离线,不是画DIF的背离线,画背离现在还得自己动手 @现代金属

举报

点亮(0) 扔鸡蛋(0) 回复

理想707a65
Lv.0
发表于 2018-2-24 19:50 复制 25楼 只看该作者

举报

扔鸡蛋(0) 回复

徐小白XX
Lv.2
发表于 2020-3-25 12:50 复制 26楼 只看该作者
不准确,蛮多背离都没有画出来

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表